Gnome-Pie 0.5.5!

Gnome-Pie 0.5.5

And again: There are some little improvements and bug fixes, but nothing with extraordinary impact.

The drag’n'drop between Pies in the editor has been improved a bit. Additionally a major segmentation fault on start up when some icons were not found has been fixed. And the PPA now supports Ubuntu 13.04, Raring Ringtail!

As github removed the possiblity to host snapshot releases, I switched to so called “tags“. You can download snapshots of Gnome-Pie’s source from this URL: https://github.com/Simmesimme/Gnome-Pie/tags.

23 Responses

  1. ronan says:

    I’m using ubuntu 13.04 raring ringtail, I want to install from PPA but it needs libbamf3-0.
    I found only libbamf3-1.
    How can I do?
    I need gnome-pie, it’s awesome

  2. The Justist says:

    Not the same problem, actually, but still a problem:
    Running ‘gnome-pie’ gives:
    [MESSAGE] Welcome to Gnome-Pie 0.5.4!
    [MESSAGE] Loading Pies from “/home/justist/.config/gnome-pie/pies.conf”.

    …and then it gets a segmentation fault and shuts down.

  3. Hey, thanks for the awesome app gnome-pie, me too have updated to 13.04 and feels a huuuuuge void I cant do anything without gnomepie ;) ;) and I also recommended it to peeps so. :) please fix it so it works on 13.04

  4. Pablo says:

    Hi Simon. Are you planning on add other “semantics” like ‘Documents’ or ‘Places’ to Gnome-Pie?

  5. Hi Simon. My name is Micah and I am currently working on an Ubuntu Distribution that implements your gnome-pie application as its main system navigation tool. I was just wondering if you wanted any part in the OS’s development. Any help would be awesome, and I love your work. If you want to know more about celerity. Email me or ask for my email.

  6. umberto says:

    Hi simon, I have this problem when i try to run gnome-pie, how can i solve it? thank you!
    [WARNING] Failed to find settings file “gnome-pie.conf”! (This should only happen when Gnome-Pie is started for the first time…)
    [MESSAGE] Welcome to Gnome-Pie 0.5.4!
    [MESSAGE] Loading Pies from “/home/umbi/.config/gnome-pie/pies.conf”.
    [WARNING] Failed to find file “.gtk-bookmarks”!

  7. arktika says:

    i try to istall it from ppa in mint 16 cinnamon but the ppa does not work!!! can you fix it or you have stop to support the gnome pie program? thanks!!

    • Simon says:

      Hey to all who had problems with Gnome-Pie on 13.10 based distros! I finally managed to fix the dependency problems.

      Simply add my PPA and run an update!

      sudo add-apt-repository ppa:simonschneegans/testing
      sudo apt-get update
      sudo apt-get upgrade

      then it should work again. Sorry for the delay!

  8. Regnis says:

    I have problems with gnome-pie. It wont respond to the hotkey. I have changed to a different hotkey, but still it wont respond.

    If i try to open “Preferences”, it does not respond. When it crashes and i open it again.. it responds for a limited time or times that i press the hotkey. Is their a log that i could show it to you?

    OS: Ubuntu 13.10 32 bit (fall-back)
    Gnome-pie version: 0.5.5

  9. Infinite says:

    FYI I’ve test Gnome Pie on Fedora 20 with different DE :

    GNOME : Black square background
    KDE : Flicker icons
    LXDE : Works
    LXQT : Works
    XFCE : Works
    Openbox : Works
    MATE : Works

    That should be easier for trouble shooting or just switching DE as another workaround.

    Thanks,
    Infinite

Leave a Reply

*